Problem running Batch learning example in Edward


#1

Hi everyone,

I encountered a problem when I tried to run the batch learning example in Edward Tutorial on my laptop. It was running incredibly slow, and I am getting warnings like “Tensorflow wasn’t compiled to use SSE4.2, AVX, AVX2, and FM, but these are available on your machine and could speed up your CPU computations”. I’m using Tensorflow 1.2.0 on mac OS Sierra version 10.12.6 and the latest version of Edward.


#2

Hey mac

Are those compilation warnings new just for edward or have you always been getting them with tensorflow?
In general those compilation optimizations shouldn’t have much effect for GPU bound operations.

Have you tried increasing the batch size? If it’s very small, at least in my experience, it will take longer.
Another problem could be previous session graphs filling up your GPU memory


#3

Hi,

I haven’t tried increasing the size of the batch. I’m running this on a CPU. Is batch learning configured only for GPUs?


#4

Hi everyone,

I did get the batch learning example in tutorial to work. Thanks for your input.